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Objetivos

Conocer los fundamentos de ASP.NET
Saber crear una aplicacion web ASP.NET de tipo Web Project

Comprender el modelo Code-Behind de ASP.NET
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iQué es ASP.NET?

Es la evolucion de Active Server Pages (ASP)

ASP.NET es el framework de programacion Web dentro de
NET

e Al codificar aplicaciones ASP.NET se tiene acceso a las clases
del .NET Framework

e Permite desarrollar aplicaciones Web con un modelo “similar”
al utilizado para aplicaciones Windows

e El componente fundamental de ASP.NET es el WebForm
« Una aplicacion Web ASP.NET consta de uno o mas WebForms

En ASP.NET se permite utilizar cualquier lenguaje .NET
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Visual Studio

La gran mayoria de los sitios web con ASP.NET se
desarrolla con Visual Studio
Caracteristicas:
e Servidor Web integrado. Solo acepta conexiones locales
e Desarrollo multilenguaje
e Genera parte del codigo necesario
e Intellisense, comentado y descomentado automatico, ...

e Depuracion. Ejecucién paso a paso, breakpoints, ver
informacion en memoria, ...
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Websites y Web Projects

VS ofrece dos modos de crear una aplicacion Web con ASP.NET:

e Web Project. Desarrollo basado en un proyecto

File > New > New Project > Asp.NET (Empty) Web Application
VS crea archivo .csproj (asumiendo C#) que almacena los archivos que pertenecen al proyecto
y caracteristicas de depuracion

Estructura similar a un proyecto de consola o ventanas
Cuando se ejecuta, VS compila todo el proyecto a un solo ensamblado, antes de lanzar el
navegador web

Deploy: ensamblado + archivos .aspx

e Website. Desarrollo sin proyecto

File > New WebSite

En este caso VS asume que cada archivo en el directorio del sitio web forma parte de la
aplicacién

En este caso VS no necesita compilar el cddigo. En lugar de esto, ASP.NET compila el codigo la
primera vez que se solicita un pagina (aunque se puede utilizar pre-compilacién)

Deploy : archivos .aspx + codigo asociado (.aspx.cs, si se utiliza C-B)
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¢ Website o Web Project?

En proyectos muy pequenos, puede resultar mas
sencillo utilizar Website

Para proyectos medianos o grandes es preferible
utilizar Web Project

 Esel tipo de desarrollo que utilizaremos



Crear un Web Project
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New Project
Recent Templates [.NEI' Framework 4 - ] Sort by: [Default | Search Installed Templates Fe |
Installed Templates T Vieual C#
_ _ % ASP.NET Web Application Visual C# ype: Hisua
Visual Basic = An empty project for creating an
4 Visual C# application with a Web user interface
Windows =t ASP.MET MVC 2 Web Application Wisual C#
Web
Office =of ASP.MET Empty Web Application Visual C#
Cloud -
Reporting Ecﬁ ASP.MET MVC 2 Empty Web Application Visual C#
SharePoint -
Silverlight (i\ﬁ;/’ ASP.MET Dynarnic Data Entities Web Application Visual C#
Test L
WCF Cﬁ; ASP.NET Dynamic Data Ling to SQL Web Application Visual C#
Workflow L
Visual Co+ @ch| ASP.NET AJAX Server Control Visual C#
Visual F# Ex
Other Project Types Ac| ASP.NET AJAX S C | Extend Visual C#
Database ﬂj;‘c . erver Contro ender 1sua
Muodeling Projects
Test Projects ﬂj-ﬁcﬁ ASP.MET Server Control Visual C#
Online Templates
Name: WebApplication
Location: ChUsers\dotMNet\DocumentstVisual Studic 20100Projects', -
Solution: [Create new solution v]
Solution name: NebApplication || Create directory for solution
|| Add to Subversion
L




Version del .NET Framework

[ WebApplication A X
Application
Configuration: | N/A Platform: | N/A
Build
Web Assembly name: Default namespace:
WebApplication WebApplication
Package/Publish Web -
Target framework: Cutput type
Package/Publish SQL [.NET Framewerk 4 »!| [ Class Library
JMET Framework 2.0
Sitverlight Applications MET Framework 3.0
MET Framework 3.5

] Assembly Information...
Build Events MET Framework 4

Install other frameworks..,
FESOUrces

Resources
Specify how application resources will be managed:
Settings
@ Icon and manifest

A manifest determines specific settings for an application. Te embed a custom manifest, first add it to
your project and then select it from the list below.

Reference Paths

Signing Tcon:

Code Analysis (Default Icon) . E] W

Embed manifest with default settings

) Resource file:



Crear una pagina Web

Add Mew Item - WebApplication

(2 it

Installed Templates

4 Visual C#
Code
Data
General
Web
Windows Forms
WPF
Reporting
Sitverlight
Workflow

Online Templates

Mame: WebForml aspx

Sort by: | Default

‘Web Form

Web Form using Master Page

Web User Control

Class

Master Page

Mested Master Page

HTML Page

Style Sheet

JSeript File

AJpX-enabled WCF Service

ASP.MET Handler

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Visual C#

Search Installed Templates
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— Type: Visual C#
A form for Web Applications

ve

Solution Explorer (sobre el nombre del proyecto) > Add > New Item



Crear una pagina Web

o8 WebApplication - Microsoft Visual Studio

File Edit View Project Build Debug Team Data Tools Architecture Test Analyze Window Help
HE AR R | Iﬁl # =a f_"nl -~ ‘-H'_:;| '3 ﬂ|Debug v||@|c|ienﬂDmode
N e = = =R P YT @ < a7
WebForml.aspx >
4 Standard ol 1 «<¥%@ Page Language="C#" AutoEventWireup="true™ CodeBehind="WebForml.aspx.cs"
Pointer Inherits="WebApplication.WebForml"” %>
AdRotator
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.8 Transitional//EN" "http://
BulletedList www.w3.org/TR/xhtml11/0TD/xhtmll-transitional.dtd">
Button
Calendar =|<html xmln http://www.w3.0org/1999/xhtml">
& [l<head runat="server">
CheckBox 7 <titler</title>
CheckBoxList 8 | </head>
DropDownList 9 E<body>
FileUnload 18 [ <form id="forml" runat="server">
e ploa E 11 B <divs
HiddenField
A Hyperlink </div>
= 14 </form>
& Image 15 | </body>
ImageButton 6 | </html>
B ImageMap
A Label
LinkButton
ListBox
B Literal L9
@ Localize
E Multiview
71 Panel
£l PlaceHolder
(*  RadioButton
§E RadioButtonList
de|  Substitution
&  Table
TextBox
= W00% - 4
O

View 2
[ ... PAALEY B Docume.. o D= || = E| vk

. ErrorList B Task List B Output B8 Test Results B2, Find Results1 I§§ Pending Changes

Ready

v| | =% B < | (8 Install Web Components |} =

A 2

W e

|8 z ©

Solution Explorer
2 2EEE
\Z8 WebApplication
> [=d| Properties
> [ References
=3 Web.confi
WebForml.aspx
‘%] WebForml.aspx.cs
% WebForml.aspx.designer.cs

b4
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Crear una pagina Web

Los controles (Label, Button,
Text Box, ...) se pueden:

e Escribir manualmente en vista
de codigo

o Arrastrar de "ToolBox" a la vista
de diseno o a la de codigo

La ventana "Properties” permite
configurar los controles

Properties

Buttonl <BUTTOM>

B el

a
AccessKey
TabIndex

4
BackColor
BorderColor
BorderStyle
BorderWidth
CssClass
Font-Bold
Fant-Italic

Font-Mames

Font-Owverline

Font-Size

Font-5Strikecut

Fant-Underline

ForeColor

T

- [

MotSet

False

False

False

False
False

Button

SEMYEr




Crear una pagina Web

s
e WebApplication - Microsoft Visual Studio

File Edit View Project Build Debug Team Data Format Tools Architecture Test Analyze Window Help

"_J'leﬂﬂ|& aﬁ:‘_‘,|"] S | "::!;| b ﬂ|Debug -||E§|c|lenﬂDmode -||§1§E;§@'IngtaIIWebComponents [
: & | Z 2 [[ximeir ]| @ o[i [(Newlnline Style) ab? Ty | [ (None) (Default Font) uSze) -|| Bl 2 U | A 2

RadicButtonList

i¢| Substitution
0 Table
TextBox -

Pl b

UseSubmitBehavior True
WalidatinnGraun

Text

The text to be shown on the button,

Vi 35 Toolbox [ -:-curne. L3 Design [ Source E||<body>||<form#forml>||<div>| <asp:Button#Buttonl = |E|

‘_l Error List B Task List B Output BB Test Results B Find Results 1 g Pending Changes

. E . B

Col 65 Chi5

Toolbox Properties
4 Standard =l<html xmlns="http://www.w3.0rg/1999/xhtml"> Buttonl Systern.Web.ULWebControls.Button -
k  Pointer —<head runat="server"» Al =1
9 AdRotator h <;1t1e><!t1tle> g | = |J
; </head>
BulletedList S<body> AccessKey
Button 1 = <form id="forml" runat="server”:> Tahlnd
Calendar Ik <div> snee
<br />
CheckBox <asp:label ID="Labell" runat="server"” Text="Label":</asp:Label> BackColor
CheckBoxList 1 &nbsp;&nbsp; BorderColor
DropDownlList ] <Zsp;Tex;Bo}( ID="TextBox1l" runat="server"></asp:TextBox> BorderStyle MotSet
<br f> <br />
FileUpload ] <asp:Button ID="Buttonl"™ runat="server"” Text="Button” /> BorderWidth
HiddenField 1 <fdive CssClass
A Hyperlink 18 </form> Font
& Image <‘;:°d{> ForeColor
</html> Text Button
ImageButton .
o I M
[ tmageMap CausesValidation  True
A Label ClientlDMode Inherit
LinkButton Label CommandArgumer
; ListBox CommandMame
E! Literal e Enabled True
& Localize EnableTheming True
B MultiView EnableViewState True
77 Panel OnClientClick
[ PlaceHolder :E.stliackUrl
(&  RadioButton " .
. ToolTip
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Tipos de archivo en una aplicacion ASP.NET

En la ventana "Solution Explorer" podemos encontrar:

e .aspx: paginas Web ASP.NET. Contienen la interfaz de usuarioyy,
opcionalmente, codigo.

e .ascx: controles de usuario.
e .asmx o .svc: servicios Web ASP.NET
e web.config: archivo de configuracion de la aplicacion Web

global.asax: permite definir variables globales y reaccionar a
eventos de la aplicacion (arranque de la aplicacién, inicio de una
sesion, ...)

« No se crea por defecto. Si se necesita, hay que afiadirlo.
e .cs: codigo C# asociado a una pagina .aspx (code-behind)
e .master: paginas maestras (Master Pages)
e Otros componentes: imagenes, archivos XML, hojas de estilos, etc.
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ToolBox

La caja de herramientas agrupa
distintos tipos de controles que se
pueden utilizar en una pagina

ASP.NET

e Standard:
« controles ASP.NET

e Validation
» controles de validacion

e HTML

« controles HTML estaticos (tradicionales)

Toolbox

4 Standard

Pointer
AdRotator
BulletedList
Button

AR

Calendar
CheckBox
CheckBoxList
CropDownList
FileUpload
HiddenField
HyperLink

=]

g HI Y

=

0 View
4 Wizard
#  Xml
» Data
» Walidation
» Mavigation
> Login
» WebParts
» AJAK Extensions
» Dynamic Data
» Reporting
> HTML
» General




Modelo de cédigo

VS soporta dos modelos para codificar paginas Web:

e Inline code:
« (Codigoy etiquetas HTML se almacenan en tinico archivo .aspx
« (Codigo se encierra en uno o mas bloques <script>
« Se puede hacer debug, utilizar IntelliSense, ...
« Solo en Website

e (Code-Behind:

« Separa cada pagina en:
.aspx, que contiene etiquetas HTMLy controles ASP.NET
.aspx.cs, que contiene el cdédigo fuente de la pagina

.aspx.designer.cs, que contiene codigo generado automaticamente (bdsicamente,
definiciones de controles)

» Separacion clara de la interfaz de usuario
- En Websitey en Web Project, con pequefias diferencias



Ejemplo
* Veamos un sencillo ejemplo, codificado con los dos modelos
FJ =] e
[ Test Page + ”

*§ - Google P| A B e -
Click Me! [ Firefox | e

Jr: Test Page | + | B

€= [} localhost454/TestFormCe 7 7 C'H':"* Google P| A B & -

& [ | localhost9454/TestFormCe 77 7

Current time: 10:12-28




Ejemplo de modelo Inline code

<%@ Page Language="C#" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.0rg/TR/xhtml11/DTD/xhtml11.dtd">
<script runat="server">

protected void Buttonl Click(object sender, EventArgs e)

{
Labell.Text = "Current time: " + DateTime.Now.ToLongTimeString();
}
</script>

<html xmlns="http://www.w3.0rg/1999/xhtml">
<head id="Headl" runat="server">
<title>Test Page</title>
</head>
<body>
<form id="forml" runat="server">
<div>
<asp:Label ID="Labell" runat="server" Text="Click Me!" />
<br />
<asp:Button ID="Buttonl" runat="server" OnClick="Buttonl Click" Text="Button" />
</div>
</form>
</body>
</html>

TesFormlInline.aspx



Ejemplo de modelo Code-behind (.aspx)

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind ="TestFormCodeBehind.aspx.cs"
Inherits="WebApplication.TestFormCodeBehind" %>

<IDOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11l.dtd">
<html xmlns="http://www.w3.0rg/1999/xhtml">
<head id="Headl" runat="server">

<title>Test Page</title>

</head>
<body>
<form id="forml" runat="server">
<div>
<asp:Label ID="Labell" runat="server" Text="Click Me!"></asp:Label><br />
<br />
<br />
<asp:Button ID="Buttonl" runat="server" OnClick="Buttonl Click" Text="Button" />
</div>
</form>
</body>
</html>

TesFormCodeBehind.aspx



Ejemplo de modelo Code-behind (.aspx.cs)

using System;

namespace WebApplication

{
public partial class TestFormCodeBehind : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{
}
protected void Buttonl_Click(object sender, EventArgs e)
{
this.Labell.Text = "Current time: " + DateTime.Now.ToLongTimeString();
}
}
}

TesFormCodeBehind.aspx.cs



// <auto-generated>

79 This code was generated by a tool.

//

A Changes to this file may cause incorrect behavior and will be lost if

// the code is regenerated.

// </auto-generated>

f ] == oo

namespace WebApplication {
public partial class TestFormCodeBehind {
protected global::System.Web.UI.HtmlControls.HtmlHead Head1l;
protected global::System.Web.UI.HtmlControls.HtmlForm forml;
protected global::System.Web.UI.WebControls.Label Labell;

protected global::System.Web.UI.WebControls.Button Buttonl;

TesFormCodeBehind.aspx.designer.cs
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